これはエクセル(CSV)の仕様です。
・先頭の0が消えないように入力する方法
セルの表示形式を数値から「文字列」に設定してから数字を入力してください。
・先頭の0が消えないようにcsvを開く方法
【初期設定】
一度設定していただくことで、以降設定が有効になります。
1.Excelを新規に空白のブックで開き、[ファイル]を選択します。
2.[その他]の中にある[オプション]をクリックします。
3.[データ]>[レガシ データ インポート ウィザードの表示]>[テキストから(レガシ)] にチェックを入れ、[OK]をクリックします。
以上で初期設定は完了です。
【2回目以降】
1.Excelを新規に空白のブックで開きます。
2.[データ]>[データの取得]>[従来のウィザード]>[テキストから(レガシ)]をクリックします。
3.開きたいファイルをインポートします。
4.テキストファイルウィザードで、[コンマやタブなどの区切り文字によってフィールドごとに区切られたデータ]を選択し、[次へ]をクリックします。
5.[区切り文字]で、[コンマ]のみにチェックを入れ、[次へ]をクリックします。
6.[データのプレビュー]より、文字列にしたい列を選択、[列のデータ形式]を[文字列]に選択し、完了をクリックします。
7.表示させるExcelのセルを選択し、[OK]をクリックします。
8.この設定をすると0が消えずに表示されています。